Error al crear Controlador

edited febrero 2010 in Principiantes
Hola a todos, tratando de seguir el ejemplo de la TIENDA paso a paso cree la BD y luego la tabla productos, cuando intento acceder mediante <!-- m --><a class="postlink" href="http://localhost/proyecto/productos">http://localhost/proyecto/productos</a><!-- m --> le doy la siguiente opcion:
Deseo crear un controlador StandardForm de la tabla 'productos'

despues de darle aceptar me sale lo siguiente:

Se creó correctamente el modelo 'productos' en models/productos.php
Error: No se pudo escribir en el directorio, verifique los permisos sobre el directorio

No he podido seguir, le quito los atributos de lectura a las carpetas y automaticamente vuelve y se colocan solos.

Gracias por cualquier ayuda.

Comentarios

  • edited 4:58
    No tienes que quitar los de lectura, sino añadir los de escritura.
  • edited 4:58
    A mi me pasa lo mismo pero estoy dentro de mi computadora
    No entiendo porke no puede escribir
  • Quizas pueda ser un bug, pero entienda que el interactive solo genera 3 lineas de codigo no creo que hay que alarmarse por eso o si?

    Creo que estas pocas lineas es lo que hace el interactive...
    &lt;?php
    class MiClassController extends StandardForm{
    
    }
    

    Éxito!
  • edited 4:58
    Que sistema operativo utilizas?
    Que instalación de servidor? wampp xampp o la estandar de apache?

    El problema en si no es de Kumbiaphp sino de tu servidor apache o del sistema operativo... necesito los datos que mencione para poder ayudarte a resolver el problema

    Slds
    Vlad
  • edited 4:58
    En mi caso uso WAMP sobre un XP al usar codder me da dos errores en donde me dice $Kumbia is undefinided

    Complemento. Esto es lo que aparece.

    errorx.th.jpg

    Ahi dicen ke les notifiquemos =P
  • Buenas compañeros pues la verdad tengo el mismo problema que richasas
    Se creó correctamente el modelo 'productos' en models/productos.php
    Error: No se pudo escribir en el directorio, verifique los permisos sobre el directorio
    pero viendo el ejemplo de la tienda dice q se creo el controlador correctamente en la direccion apps/default/controllers/productos_controller.php
    pero me dio curiosidad x entrar a esa direccion a ver si lo creaba y en efecto ahi estaba productos_controller.php
    Entonces despues segui normalmente me puse a registrar productos y las cosas y me di cuenta q me el programa me daba la libertad de poder escribir el id del producto a mano osea no se cumplia el atributo autoincrement q se le da en la creacion de la tabla y otro error q sigue es q al yo poder escribir el id a mano trate de agregar una fila con un mismo id ya creado con anterioridad y para mi sorpresa dijo se inserto el registro... revise a ver q habia hecho y simplemente cambio los demas campos como si se estuviera haciendo una modificacion de registro me imagino que debe ser x el error q se produjo al crear el controller de producto entonces de verdad necesito para solucionar este problema
    Yo uso SO Windows Vista LITE 5
    el servidor web XAMPP
    y netbeans para la parte de programacion bueno esto no viene al caso pero de todos modos
    si cabe destacar durante la instalacion modifique solo el archivo config del apache le quite el # del mod_rewrite no se abra q hacerle otra cosa a parte de eso..
    AYUDA!! LO MAS PRONTO POSIBLE PLEASE!!!!!
    Necesito ayuda
  • creo que se están ahogando en un vaso de agua por 3 líneas de código que es lo que genera el interactive de kumbiaphp....

    El código generado no es mas que el nombre de una class y de quien extends mas nada...
  • Que tal. me parece bueno este framework, solo q tengo el mismo problema.. tengo Windows Vista con wamp....

    Cual es la solución entonces??,, me sale que no tengo permisos de escritura sobre el directorio..
  • edited 4:58
    Supongo ke ya no tiene sentido esto puesto ke ya no habra standarform creo no?

    A esperar el manual del Kumbia 1.0 =D
  • Supongo ke ya no tiene sentido esto puesto ke ya no habra standarform creo no?

    A esperar el manual del Kumbia 1.0 =D

    Queda el de la 0.5 que no se le esta dando soporte porque estamos haciendo uno nuevo mucho mas mantenible que el de la 0.5....

    Exitos!
  • edited 4:58
    Después de ver el código fuente que da la página del formulario StandardForm de productos veo que no se están interpretando correctamente las marcas "<?=" y "?>"El error está en la configuración que trae PHP en paquetes como WAMP. Simplemente hay que activar "sort open tag" haciendo click sobre el icono de wampserver de la barra de tareas y en PHP->PHP Setings activar "sort open tag".

    Es una pena que no se siga manteniendo StandardForms...

    Saludos

    Vicente Martínez de Cestafe Ochoa de Eribe
  • Buenas ese componente quedo deprecated por parte del equipo de desarrollo, no estamos agregando nada de codigo ni correcciones, esto debido a la poco nivel de mantenimiento que ofrece para cuando fue creado el StandardForm, en este sentido en la version beta2 tendremos un nuevo Scaffold con muchas mas bondades y niveles de personalizacion de cara al usuario mas avanzadas...
Sign In or Register to comment.