Ayuda use_helper

Hola, estoy haciendo paso a paso un tutorial de una tienda de productos, resulta que en el archivo descomprimido del tutorial todo funciona a la perfección, pero al momento de hacerlo paso a paso en un nuevo proyecto con la versión 0.5 estable, no me graba la información correspondiente a la tabla de artistas usando el siguiente codigo:

class ProductosController extends StandardForm {
public $scaffold = true;
public function __construct(){
$this->use_helper("artista");
}
}

en el navegador me aparece todo bien, aparece el link de nuevo y al momento de quere crear un nuevo artista me da la opcion... pero al momento de dar Guardar, no lo hace, será que esta nueva versión tiene algun bug en los helper?

las estructuras de mis tablas son:

CREATE TABLE `tienda1`.`productos` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT,
`nombre` varchar(45) NOT NULL,
`artista_id` int(11) NOT NULL,
`precio` decimal(10,2) NOT NULL,
`cantidad` int(10) unsigned NOT NULL,
PRIMARY KEY (`id`)
) ENGINE=InnoDB AUTO_INCREMENT=4 DEFAULT CHARSET=utf8;

CREATE TABLE `tienda1`.`artista` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT,
`nombre` varchar(45) NOT NULL,
PRIMARY KEY (`id`)
) ENGINE=InnoDB AUTO_INCREMENT=3 DEFAULT CHARSET=utf8;

Gracias por la ayuda

Comentarios

  • edited 7:06
    hola Andres, encontraste la solucion? a mi me pasa lo mismo, cuando lo haga funcionar posteo aca, saludos.
  • edited 7:06
    te recomiendo que hagas un debig a los sql

    desde el model que estas utilizando debes escribir:


    // Impresion por pantalla
    public $debug = true;

    o
    //almacena archivo log
    public $logger = true;


    con esto podras ver si se hace un insert a la base.
  • No hay nadie todavia q alla podido encontrar una solucion?????
    estoy haciendo tambien el tutorial con la version 0.5 estable no me inserta cuando le doy guardar
  • edited 7:06
    Yo tengo el mismo problema. He usado el DEBUG pero no muestra ningun comando SQL.
  • edited 7:06
    Hola!
    No se si sirva de ayuda, pero a mi me paso lo mismo con unas tablas y con otras no.

    Analizando mi estructura de datos descubri que kumbia solo guarda/actualiza los datos si cada campo en la tabla permite guardar NULL; con excepcion del id propiamente dicho.

    O sea, prueben con editar la estructura de la tabla para que los campos puedan guardar NULL. Logicamente, esta practica nos obliga a hacer una buena validacion de los datos ANTES de guardar.

    Saludos. <!-- s:lol: --><img src="{SMILIES_PATH}/icon_lol.gif" alt=":lol:" title="Laughing" /><!-- s:lol: -->
Sign In or Register to comment.