Instalación kumbia con ubuntu

smrsmr
edited febrero 2010 in Principiantes
Hola a todos!

Les comento mi caso...
Estoy empezando con kumbia 1.0b. Hasta ahora las pruebas que había hecho han sido con xampp bajo windows y ningún problema...

Ahora estoy intentando instalar el kumbia 1.0b en un servidor con un ubuntu server 8.10 actualitzado con el Lamp con PHP 5.2.6 y Apache 2.2.9. El problema és que cuando abro la web de bienvenida del kumbia veo el texto de bienvenida, pero sin formato ni imágenes. Como si no encontrara el css.

He seguido los manuales de instalación y configuración del php y apache que teneis en la wiki pero nada...

¿Me pueden ayudar?

Muchas gracias!

Comentarios

  • Es porque no haz activado correctamente el mod_rewrite del apache... te dejo una Guía de instalación de KumbiaPHP
  • smrsmr
    edited 5:04
    Primero de todo gracias por responder tan rápido.

    Ya había seguido el manual, de todas formas lo he vuelto a probar.

    # a2enmod rewrite
    Module rewrite already enabled

    Lo he probado sin haber reiniciado el apache y no ha funcionado, entonces lo he reiniciado y tampoco...

    ¿Alguna sugerencia?
  • Ok, veo que no haz seguido los pasos de la Guía de Instalación, eso que te pasa es que no haz hecho que el apache interprete los .htaccess

    <Directory "/to/document/root">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    Creo que ahí queda claro, sino sigues los pasos sera dificil que te funcione como debe ser...
  • smrsmr
    edited 5:04
    Deivinson,

    Como te he dicho en los dos mensajes he seguido el manual. Quizás no me explicado bien, pero lo debo haber repetido 10 veces.

    Así es como está el 000-default

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride All
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>

    También está el mod_rewrite.load en el directorio mods_enabled

    He provado a instalar la version de kumbia 0.5 y esta si que me dice que no está instalado el mod_rewrite.

    También he comprobado que el apache esté leyendo el 000-default y puedo decir que funciona bien...

    El .htaccess está tal qual viene con la versión 1.0 y está ubicado en el directorio public del kumbia:
    DirectoryIndex index.php
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule ^$ public/ [L]
    RewriteRule (.*) public/$1 [L]
    </IfModule>

    El directorio del kumbia está en /var/www/

    A ver si con esta información sabes que puede ser y me puedes ayudar...
  • verifica el .htaccess que esta en el app/public/...alli tambien hay uno...

    Me gustaria exactamente el error te podrian salirte varias cosas relacionada con el mod_rewrite del apache... si me dices exactamente el error mejor...

    Ejecuta desde tu consola...

    $ sudo a2enmod rewrite; /etc/init.d/apache2 restart

    Una vez con eso vuelve a ejecutar el KumbiaPHP y me dices...
  • smrsmr
    edited 5:04
    Por fin!

    Gracias a este comentario:
    verifica el .htaccess que esta en el app/public/...alli tambien hay uno...

    Por algún motivo que desconozco no se había copiado el .htaccess en la raiz del kumbia, solo lo tenia en el app/public

    Solucionado!
    Muchas gracias por la ayuda!
Sign In or Register to comment.