Bug

edited mayo 2010 in Beta1
Buenos dias, antes que nada perdon si estoy escribiendo esto en el foro incorrecto pero dentro del foro de bugs no me dejaba escribir.
Estoy empezando en el uso del framework y realmente me ha gustado mucho.
Les dejo el error que encontre:

Deprecated: Function ereg_replace() is deprecated in K:\xampp\htdocs\Admin\core\libs\db\active_record_base\active_record_base.php on line 2275

Deprecated: Function ereg() is deprecated in K:\xampp\htdocs\Admin\core\libs\db\active_record_base\active_record_base.php on line 2276


Estoy utilizando php 5.3.0, kumbiaPHP version 1.0b1.
Un error similar encontre en joomla essencia (Una compilacion que hacen en Argentina), y la solucion fue editar los archivos remplazando ereg_replace por preg_replace.
En caso que los pueda ayudar en algo cuenten con migo

Comentarios

  • edited 12:00
    Buenas, ya en el equipo de desarrollo sabemos de esto, sin embargo KumbiaPHP esta escrita en PHP 5.2.x...

    PHP 5.3.x aún es una versión de desarrollo que presenta bug, por ejemplo en los últimos updates de PHP 5.3.x han arreglado un bug que afectaba a KumbiaPHP y era los parse de los archivos .ini...

    Nosotros haremos una versión de KumbiaPHP exclusiva para PHP 5.3 el cual no es solo una versión mas de PHP, hay mejoras a nivel de lenguaje que afectan a todos los framework de PHP...

    Lo óptimo es que estes trabajando con PHP 5.2.x

    Éxitos!
  • edited 12:00
    Muchas gracias por tu pronta respuesta!!
    Saludos y sigan asi.
Sign In or Register to comment.