Error en dispatcher, no tengo ni idea d q sea

edited octubre 2010 in Beta1
Buenas tardes. Soy nueva usando Kumbia y en todo este asunto, hice la instalacion siguiendo las instrucciones del manual y luego de eliminar un par de errores logre llegar a la pantalla de bienvenida, luego quise probar con el hola Kumbia y me salio este error:

<?php
class SaludoController extends AplicationController {
public function index() {}
}
?>

Fatal error: Class 'SaludoController' not found in C:\wamp\www\Kumbia\core\kumbia\dispatcher.php on line 54

Espero me puedan ayudar, gracias de antemano

Comentarios

  • edited 12:00
    hola
    déjanos ver el código de tu vista y de tu controller

    que versión estas usando?
    que versión de php tienes en el servidor?
  • edited 12:00
    Hola! Primeramente gracias por responder.
    El codigo de mi vista es:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">;
    <html xmlns="http://www.w3.org/1999/xhtml">;
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <!-- TemplateBeginEditable name="doctitle" -->
    <title>Documento sin título</title>
    <!-- TemplateEndEditable -->
    <!-- TemplateBeginEditable name="head" -->
    <!-- TemplateEndEditable -->
    </head>

    <body>
    &lt;h1&gt;Hola Kumbia&lt;/h1&gt;
    </body>
    </html>

    Y mi controller es:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">;
    <html xmlns="http://www.w3.org/1999/xhtml">;
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>saludos_controller.php</title>
    </head>

    <body>
    <ol>
    <li>&lt;?php</li>
    <li>class SaludoController extends AplicationController {</li>
    <li>    public function index() {}<br />
    </li>
    <li>}<br />
    </li>
    <li>?&gt;</li>
    </ol>
    </body>
    </html>


    Lo genere a partir de un programa, xq con el bloc de nota me daba error.
    Mi version de Kumbia es: kumbiaphp_1.0b1

    =)
  • El problema segun veo es que no estas siguiendo como si indica el tutorial del Hola Mundo
  • edited 12:00
    usaste un generador de código y eso esta mal.... de ellos apártate <!-- s:lol: --><img src="{SMILIES_PATH}/icon_lol.gif" alt=":lol:" title="Laughing" /><!-- s:lol: -->

    revisa el tutorial que indico deivinsontejeda y usa un editor que no genere código, puedes usar notepad++ o komodo edit..... aquí hay un listado de editores para php usa uno de esos cuando estés haciendo el ejemplo

    Saludos
  • edited 12:00
    Gracias por los consejos!! Lo logre =)
  • edited 12:00
    que bueno <!-- s:) --><img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" /><!-- s:) -->
Sign In or Register to comment.