Ahora KumbiaPHP está en Slack!!

Si deseas contactar con nosotros y de forma rápida, estamos en Slack:

http://slack.kumbiaphp.com/

Problemas con Eclipse + XDebug + Kumbia PHP Beta2

edited mayo 2012 in Beta2

Buenas,

Alguien ha depurado Kumbia B2 desde Eclipse con XDebug por HTTP Debug Sessions. En el momento tengo un problema con el PUBLIC_PATH ya que está quedando con los 6 caracteres ?XDEBUG de los parámetros enviados por URL (GET) para depurar.

Ejemplo de error:   <link href="/wkspc/golastica/?XDEBUGcss

Observando el código de Kumbia, me encontré con el define del PUBLIC_PATH que deja los 6 caracteres:

if ($_SERVER['QUERY_STRING']) {
    define('PUBLIC_PATH', substr(urldecode($_SERVER['REQUEST_URI']), 0, - strlen($_SERVER['QUERY_STRING']) + 6));
} else {
    define('PUBLIC_PATH', $_SERVER['REQUEST_URI']);
}

¿ Cuál es el objetivo de dejar estos 6 caracteres ?
¿ Alguien tiene otra alternativa de usar XDebug desde Eclipse pero que no afecte el funcionamiento de Kumbia B2 a la hora de depurarlo ?

Por otro lado:

Eclipse + XDebug + easyXDebug + Kumbia B2 funcionan perfecto


Gracias

Comentarios

  • setea el PUBLIC_PATH con una ruta estatica mientras trabajas con el XDebug

  • hmmm, bueno sí es una alternativa que había considerado pero la verdad no me convence mucho esa solución ... pero sí es una forma ...

    Esa línea strlen($_SERVER['QUERY_STRING']) + 6 debe hacer algo en el framework, ¿ saben para qué es utilizada ?
  • es para quitar el "_url=/" del QUERY_STRING 
  • este si es un gran problema pro que no se puede enviar GET
    alguien lo logro solucionar este bug??
Sign In or Register to comment.