Ahora KumbiaPHP está en Slack!!

Si deseas contactar con nosotros y de forma rápida, estamos en Slack:

http://slack.kumbiaphp.com/

En mi proyecto tengo un problema con el index

edited octubre 2012 in Dudas/Problemas
Monte mi aplicación en windows basado en xampp todo funcionaba perfectamente
luego migre a debian para montar la apliación y resulta que al poner en la url  "/localhost/miproyecto/index" no se visualiza nada 
al quitar "/localhost/miproyecto" marcha bien  no entiendo e revisado rewrite la prioridad de index 

pd: en windows funcionaba perfecto.


 spirt beta 2

Comentarios

  • prueba a colocar esto en el .htaccess de la carpeta del proyecto
    Options -Multiviews

    En la primera linea.

    Saludos...!!!
  • Muchas gracias funciono perfectamente 

    Saludos...
  • No es recomendable usar el: Options -Multiviews

    Lo que hace es que si no existe el fichero llamado "index", Apache busca un fichero "index" con cualquier extensión. Para empezar es lento y segundo puede causar problemas de seguridad.

    Pero lo peor es que al usarlo, muchas veces no funcionan las redirecciones del .htaccess.

    Estoy preparando un post en el blog, sobre como usar bien las URLs. Aunque no es de PHP, es sólo de http,  pero lo usamos también en PHP y otras partes, como para el SEO.

    Pero en tu caso, dos cosas:
    1. Nunca llames por URL a un directorio sin el "/" final.
    Lo que hace apache es buscar en tu caso si existe el fichero "miproyecto", y si no existe ese fichero, pero si un directorio llamado "miproyecto",  redirecciona a "miproyecto/". Lo cual es lento.

    2. El URL de tu proyecto es xxx/miproyecto/ no necesitas añadir el index.
    Es más no es recomendable. Cuando creas enlaces a tu proyecto usa siempre xxx/miproyecto/, no xxx/miproyecto/index.

    Los 2 puntos influecian en ser más rápidos y correctos. Y también en el SEO.
    Si apuntas a tu "miproyecto/" y a "miproyecto/index" que tienen lo mismo, para cualquier buscador sera una pagina repetida y repartirá y penalizara el SEO.
  • Perdón, no se debe usar el Options Multiviews.

    Pero la vista, a veces engaña.
    Arriba pone: Options -Multiviews
    Con el "-" delante indica que no se use.
    Asi que no es recomendable el Options Multiviews  sin el "-"
Sign In or Register to comment.