Intalar Kumbia PHP en MAMP Mac
  • Hola que tal, soy un nuevo usuario aprendiendo a utilizar Kumbia PHP. Quisiera ver si me pueden ayudar, tengo un sitio trabajando en un servidor con Kumbia PHP sin embargo quiero trabajar en modo localhost (ya me descargue los archivos) para trabajar sin conexión a internet y cuando abro la pagina de inicio me muestra el siguiente error:
    KumbiaError: No tiene Mod-ReWrite de Apache instalado
    Debe habilitar/instalar mod_rewrite en su servidor Apache. Consulte para más información:

    Ya intente hacer lo que en este post mencionan: http://foro.kumbiaphp.com/discussion/1066/error-apache/p1 pero no me funciona. Quisiera saber si a alguien ya le ha pasado esta situación y saber como lo resolvió. Ya intente hacer los cambios que mencionan posteriormente reiniciar el servicio php pero me muestra el mismo error. 
  • Hola loge, la verdad es que desconozco como es en Mac, pero haciendo una búsqueda en Google sobre MAMP y mod_rewrite encontre una que dice:

    1. Habilitar mod_rewrite
    Abrir httpd.conf ubicado en /MAMP/conf/apache/ y buscar la siguiente línea:

    #LoadModule rewrite_module modules/mod_rewrite.so

    Quitar el comentario removiendo el signo numeral (#) al principio de la línea y luego reiniciar el servidor apache.

    Avisanos si con eso alcanza, o si lo has resuelto por favor indica la respuesta.
    Saludos

  • Muchas gracias por tu respuesta manouman pero no me ha funcionado el archivo /Applications/MAMP/conf/apache/httpd.conf tiene por default deshabilitado la linea de comentario por lo que el LoadModule debiera estar habilitado (Sin #).

    Ya intente agregar:

    <Directory />
        Options FollowSymLinks
        AllowOverride All
        Order deny,allow
        Deny from all
    </Directory>

    Reinicio el servidor APACHE y sigo con el mismo mensaje de error. Alguna otra ayuda se los agradecería mucho.
    Saludos!
  • Pero estas haciendo un deny from all, al final.
  • Bueno, vamos por partes entonces, en algún archivo crea <?php phpinfo();?> y correlo.
    Luego fijate si en "Loaded modules" aparece "mod_rewrite", como para confirmar que el módulo está cargado y ahí vemos como seguimos.
    Saludos
  • Hola, gracias nuevamente manouman.

    Ya hice una archivo para ver la información de PHP y si me aparece el mod_rewrite como uno de los Modulos cargados.

    image

    Que procede?
  • Mira si has copiado los .htaccess 
    También mejor que uses la beta2 de Kumbiaphp
  • Hola nuevamente...
    Les comento que al fin pude correr el framework. joanhey efectivamente se trataba del .htaccess ya que el sitio que quiero montar en localhost tenia la siguiente configuración.

    suPHP_ConfigPath /home/todov0/public_html

    <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteRule    ^$ public/    [L]
        RewriteRule    (.*) public/$1 [L]
    </IfModule>

    AddHandler x-httpd-php52 .php


    Lo que hice fue crear un nuevo proyecto instalando desde cero Kumbia PHP (beta2) al descomprimir y correr el proyecto si me muestra la pantalla de bienvenida. Lo que he estado haciendo es mandando los módulos, vistas y controladores uno por uno y así lograr correr la aplicación sin problemas.

    image

    Muchas gracias por todo. Les agradezco su ayuda ahora solo falta hacer compatible la configuración del htacces para las rutas amigables en este nuevo que estoy creando...