Nombre de tablas en modelo kumbia

Hola comunidad ¡¡¡
¿Se puede usar guion bajo ( _ ) en el nombre de las tablas?.
estoy haciendo usando tablas relacionadas con el modelo de kumbia, pero si quiero usar como nombre de la tabla "tipo_divisa".
cuando hago asociaciones me sale el siguien mensaje:

KumbiaException: No se encontró la Clase "TipoDivisa"
Es necesario definir una clase en el modelo 'tipo_divisa' llamado 'TipoDivisa' para que esto funcione correctamente.

lo hice correctamente como dice el mensaje pero logre poder usar la asociacion, me podrian ayudar a entender como trabajo con asociaciones de tablas que tienen en el nombre un _.
Desde ya muchas Gracias de antemano

Comentarios

  • Puedes usarlo sin embargo debes declarar el nombre de tu clase tal y como te lo esta diciendo Kumbia con notacion camelizada:

    KumbiaException: No se encontró la Clase "TipoDivisa"
    Es necesario definir una clase en el modelo 'tipo_divisa' llamado 'TipoDivisa' para que esto funcione correctamente.
    <?php
    
      class TipoDivisa extends ActiveRecord {
    
      } 
    
    ?>
    
  • Entonces como lo usaria por que me dice el siguiente mensaje por que no doy en el blanco.
    ahora paso a mostrarles el codigo que que hice para ver si tengo algo mal programado.

    Modelo:tipo_divisa.php
    class TipoDivisa extends ActiveRecord
    	{
    	public function __construct()
    		{
    		$this->has_many('propiedades');
    		}
    	}
    

    Modelo:propiedades.php
    class Propiedades extends ActiveRecord
    	{
    	public function __construct()
    		{
    		$this->belongs_to('provincias');
    		$this->belongs_to('tipo_divisa');
    		}
    	}
    

    Luego tengo en la vista este codigo:
    <? foreach($Propiedades->find() as $datos_propiedad): ?>
    <?= $datos_propiedad->getTipo_divisa()->nombre ?>
    <? endforeach; ?>
    

    y luego de esto me tira el siguiente mensaje:

    KumbiaException: No existe el modelo 'Tipo_divisa' para relacionar con ActiveRecord::propiedades
  • Estas usando Kumbia 0.5?
  • Estoy usando la version 0.47
  • edited 8:39
    Pensé que era el único con este inconveniente, tengo una tabla llamada "certificadohaspoliza"; para hacerla mas entendible en el modelo cree la clase llamada "CertificadoHasPoliza" y a la hora de usar el modelo da un error porque no encuentra "Certificado_haspoliza".

    Quien le agregó el "piso"?

    Alguna solución, uso la versión 0.47.
  • Saludos, Si crean el nombre de la tabla con el siguiente nombre por ejemplo nombre_tabla el archivo del modelo se debe llamar nombre_tabla.php y la class NombreTabla prueben con esto y avisan para documentar esta parte...
  • edited 8:39
    Gracias por la respuesta, pero no se ajusta a la pregunta que hice:

    Y si la tabla se llama nombre_has_tabla ? (dos underscore)
    Y si quiero llamar a la clase NombreHasTabla ?
    Si mi tabla se llama nombrehastabla, no puedo usar NombreHasTabla como nombre de clase?

    La intencion es que el programador este claro con las convenciones como dices tu, para documentarlas.

    Gracias de antemano.
  • Y si la tabla se llama nombre_has_tabla ? (dos underscore)
    Y si quiero llamar a la clase NombreHasTabla ?
    Esto fue exactamente lo que te respondí...
    Si mi tabla se llama nombrehastabla, no puedo usar NombreHasTabla como nombre de clase?
    Claro que lo puedes usar...
Sign In or Register to comment.