Fallos en la versión 0.5

edited mayo 2008 in Bugs y Problemas
Buenas, estoy probando la versión 0.5, y voy a ir exponiendo en este hilo todas las cosillas que vaya viendo.

Al generar interactivamente un standardform, bajo los flash que dicen que todo ha ido bien, aparece el siguiente error de php:
Notice: Undefined variable: detail in /var/www/tutorial/library/kumbia/generator/generator.php on line 192

He mirado el archivo en esa línea pero no he averiguado nada. He de advertiros que he renombrado el directorio apps/default a apps/backend, y he creado otro directorio igual que se llama frontend. Lo comento por si tiene algo que ver...

Edito: al crear un segundo standardform no ha aparecido. Tal vez el error sea porque en el primero, he llamado a una tabla con un foreign_key que llama a la segunda tabla.

Comentarios

  • edited 3:52
    Otro error.

    He insertado varios registros en el segundo standardform. Le he dado a modificar a uno,modifico, guardo y al cambiar de página por la actualización la url se ha transformado en esta:

    <!-- m --><a class="postlink" href="http://localhost/tutorial/backend/backend/ciudades/back">http://localhost/tutorial/backend/backend/ciudades/back</a><!-- m -->

    Cuando debería ser esta: <!-- m --><a class="postlink" href="http://localhost/tutorial/backend/ciudades/back">http://localhost/tutorial/backend/ciudades/back</a><!-- m -->

    Así que ahora me sale el asistente de si quiero crear el controlador "backend"

    No se en qué estado está el desarrollo de standardform en esta versión. Si aún está a medias lo dejaré estar hasta que lo arreglemos (intentaré arreglar lo que pueda yo también <!-- s:D --><img src="{SMILIES_PATH}/icon_biggrin.gif" alt=":D" title="Very Happy" /><!-- s:D -->). Si lo dábais por bueno... pues ya veis que no <!-- s:) --><img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" /><!-- s:) -->
  • edited 3:52
    A ver he encontrado y corregido un par de bugs:

    Version: 0.5
    Archivo: library/kumbia/generator/generator.php
    Línea de error: 191

    Al generar un StandardForm, aparecía un error de variable indefinida en la línea 191:

    Código anterior:
    if($p&amp;&amp;$detail&amp;&amp;!isset($form&#91;'components'&#93;&#91;$field&#91;'Field'&#93;&#93;&#91;'type'&#93;)){
    

    El valor de $detail depende de si se cumple una condición anterior, pero luego se compara su valor pudiendo no estar definida. Se corrige con isset():

    Corrección:
    if($p&amp;&amp;isset($detail)&amp;&amp;!isset($form&#91;'components'&#93;&#91;$field&#91;'Field'&#93;&#93;&#91;'type'&#93;)){
    

    El segundo bug:

    Archivo: library/kumbia/generator/browse.php
    Línea: 384
    Error: al volver de un report, si la aplicación tiene más de un app, la url se devuelve erróneamente, como comenté en el post anterior.

    Código anterior:
    Generator::forms_print("\r\n<br><center><input type='button' class='controlButton' value='Volver' onclick='window.location = \"".get_kumbia_url($app_controller."/back")."\"'></center>");

    Corección:
    Generator::forms_print("\r\n<br><center><input type='button' class='controlButton' value='Volver' onclick='window.location = \"".self::writeLocation()."/back"."\"'></center>");
  • solucionado, gracias proclamo <!-- s:D --><img src="{SMILIES_PATH}/icon_biggrin.gif" alt=":D" title="Very Happy" /><!-- s:D -->
Sign In or Register to comment.