problemas con el live search

edited septiembre 2008 in Dudas/Problemas
holas.
estoy trabajando con la ultima version del svn
0.5
estoy creando un text_field_with_autocomplete de esta manera
<?= text_field_with_autocomplete("nombre", "class: label", "action: ventas/buscar_articulos") ?>

y me lanza este error en el javascript

Ajax.Autocompleter is not a constructor

pero cuando hago esto en la version 0.47 me funciona bien.

si alguien tiene un ejemplo de hacer esto y este funcionando le agradesco su ayuda.

quizas hay que activar algo.
mmm
<!-- s:? --><img src="{SMILIES_PATH}/icon_confused.gif" alt=":?" title="Confused" /><!-- s:? -->

Comentarios

  • Reviso y te aviso eso mismo me comento un amigo que le funciona bien en la version 0.4.x y en la 0.5 falla y desconozco los motivos...
  • edited 9:33
    gracias y espero tu repuesta
  • edited 9:33
    deivison,
    no te olvides de este tema por favor, hacer si puedo solucionar mi problema con este live search
    gracias.
  • Ok, FiDeLio estoy pendiente...
  • edited 9:33
    Hola, yo lo corregi de esta forma, no es la mejor pero funciona.
    En el archivo index.phtml de la carpeta view agregue lo siguiente:
    &lt;script src='/&lt;?= $_SESSION&#91;'KUMBIA_PATH'&#93; ?&gt;/javascript/scriptaculous/unittest&#46;js' type='text/javascript'&gt;&lt;/script&gt;
    	&lt;script src='/&lt;?= $_SESSION&#91;'KUMBIA_PATH'&#93; ?&gt;/javascript/scriptaculous/scriptaculous&#46;js' type='text/javascript'&gt;&lt;/script&gt;
    
  • Hola il_pez, eso para la versión 0.5?
  • edited 9:33
    hice lo mismo, ´pero no funciona <!-- s:( --><img src="{SMILIES_PATH}/icon_sad.gif" alt=":(" title="Sad" /><!-- s:( -->
  • edited 9:33
    hola devinsontejeda, si lo hice asi en la version 0.5 y salio andando.
  • edited 9:33
    il_pez Capooooo, funciona a la perfeccion, testeado con la RC2 de la 0.5 y anda espectacularmente, muchas gracias por tu aporte!
  • se agrego la solucion al svn bajo la rev624
Sign In or Register to comment.