Problemas con date_field_tag

edited julio 2008 in Dudas/Problemas
Buenas tengo problemas con el date_field_tag() ..
no es un problema directo date_field_tag() .. sino cuando lo quiero usar en cierta situacion

por ejemplo

tengo una vista llamada index.html
<div>
<?= link_to_remote("text:","update: cuerpo", "action:prueba")?>
</div>
<div id=cuerpo>
</div>

vista prueba.phtml
<?= date_field_tag('prueba') ?>


carga el date_field_tag lo mas bien pero no funciona el calendario despligable

tambien me paso al querer cargar en el contenedor div .. un StandardForm lo cargaba pero no me funcionaban los botones..

Alguien tiene idea porque esto ?

Comentarios

  • 1->en cuanto al standardform no es posible hacer eso...

    deberias explicar un poco msa tu duda....
  • edited 5:54
    si cargo el controlado de esa forma no me deja usar el calendario que se despliega...
    si llamo la vista directamente desde el navegador funciona de 10 !

    con respecto al standardform porque no es posible ? seguramente sera el mismo problema
  • Tal ves sea un problema del xhmtl no valido, por ejemplo en id="cuerpo" le falta las comillas.
    De ultima instancia, nos pegas el código completo.

    Firefox posee varias herramientas para detectar errores en el XHTML y JAVASCRIPT.
  • edited 5:54
    buenas...
    ya lo soluciones cambiando toda la estructura de la aplicacion .. asi no lo cargo mas dentro de un div .. seria que ya no recurro mas a esa situacion ...

    como dato adicional al usar el firebug (apenas estoy aprendiendo como se usa) .. veia que no me cargaba el js del calendario
Sign In or Register to comment.