Problemas con Smarty, no muestra nada

edited agosto 2008 in Dudas/Problemas
Buenas amigos kumbieros hoy estube viendo el ejemplo de Smarty que hay en el blog creo con la version 4.7 y la verdad trabaja todo bien, ahora al hacer las pruebas en la ultima version 0.5 no me funciona, la pagina principal.tpl me muestra todo en blanco.

¿Alguien sabe cual puede ser el problema?.

bien los archivos que cree y modifique para el ejemplo son los siguientes:

En el archivo boot.ini adicioné la libreria de smarty
[modules]
extensions = kumbia.logger, mail.mail, libchart.libchart, smarty.main

y luego cree los siguientes archivos:

controllers:
saludos_controller.php
class SaludosController extends ApplicationController{
    function principal(){
        $this->variable = "Bienvenido al Framework Kumbia";
    }
}
Vista: "Siguiendo el pequeño tuto que hay en la documentacion de la 4.7"
saludos/principal.tpl

1. {* Smarty *}
2. Hola {$variable}!.

gracias de antemano por su ayuda

Comentarios

  • edited 5:44
    En la 0.5, con respecto a Smarty no se habia contemplado los nuevos criterios de multiples aplicaciones y programación modular, en estos momentos se esta trabajando en separar la logica que muestra las Vistas y encapsularla en una clase View, asimismo se estan haciendo las operaciones correspondientes para el soporte de Smarty.

    De cualquier manera gracias por el aviso <!-- s:) --><img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" /><!-- s:) -->

    Saludos.
Sign In or Register to comment.